Comments

  1. Pat says

    Won’t print, keeps saying I need JAVA and I have the latest Java. I’ve had this happen before on other coupons, what is the deal!

    • Tracie says

      I find that it has to do with the level of browser I am using. I sometimes change browsers and that helps. So, if you are using Firefox, try Internet Explorer or Chrome (etc)